Catégories
Expert Tutoriel Virtualisation

VMware ESXi : utiliser Update manager dans vCenter

Après l’installation du plugin Update Manager, ce tutoriel explique comment administrer l’outil de mise à jour des serveurs VMware vSphere ESXi.

 

Utiliser Update Manager, le plugin de mise à jour VMware ESXi

1. Se connecter à vCenter par le vSphere Client.

2. Aller sur l’onglet Update Manager au niveau du cluster ou des hosts.

3. En haut à droite, cliquer sur Attach (ou Attacher) pour sélectionner le type de mises à jour souhaité.

4. Cocher les mises à jour nécessaires : critiques ou non critiques.

5. Rechercher les mises à jour en cliquant sur Scan (ou Analyser) et en sélectionnant les paquets à chercher.

6. La partie basse de l’écran montre les serveurs présents dans le cluster et leur état. Ceux-ci sont sûrement en rouge car les dernières mises à jour n’y sont pas encore installées.

7. En bas à droite, cliquer sur Stage (Transférer) pour télécharger tous les paquets (critiques et/ou non critiques) sur le(s) serveur(s), la liste précise si l’installation de l’update nécessite un redémarrage du serveur.

8. L’étape précédente n’était que le téléchargement des mises à jours, le bouton Remediate (ou Corriger) permet de les installer.

En production, il est conseillé de mettre à jour un serveur après l’autre en profitant du HA (haute disponibilité), c’est-à-dire que les machines virtuelles vont aller sur les autres serveurs du cluster pour libérer l’hôte en maintenance, afin que l’installation des updates et que le reboot ne perturbe pas l’activité des VM.

Pour plus de précaution dans un environnement non critique, il est bien sûr possible de réaliser cette opération de maintenance en mode « sécurité » : on arrête toutes les VM, on met à jour un à un chaque serveur (au cas où une mauvaise mise à jour ferait planter un host au redémarrage) et on relance les machines en vérifiant le bon fonctionnement + mise à jour des drivers VMTools.

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *